error: module not found: jarhdf


#1

When I was trying to build HDFview3.1.3 from source in Ubuntu 18.04, I get the error information as:

(base) ps@Precision:~/Downloads/hdfview-3.1.3$ ~/Downloads/apache-ant-1.10.11/bin/ant run

Buildfile: /home/ps/Downloads/hdfview-3.1.3/build.xml
[echo]
[echo] Application: HDFView 3.1.3
[echo] Build File: /home/ps/Downloads/hdfview-3.1.3/build.xml
[echo]
[echo] Run by: ps
[echo] Build Dir: build
[echo] Base Dir: /home/ps/Downloads/hdfview-3.1.3
[echo] Dist Dir: build/dist
[echo] Java Home: /home/ps/Downloads/jdk-15
[echo] HDF libpath: /usr/local/hdf4/lib,/usr/local/hdf5/lib
[echo] HDF4 version: 4.2.15
[echo] HDF5 version: 1.10.7
[echo] Operating System: Linux 4.15.0-154-generic amd64
[echo] Debug Build: true
[echo]
[echo] running on Unix

clean:
[delete] Deleting directory /home/ps/Downloads/hdfview-3.1.3/build/classes
[delete] Deleting directory /home/ps/Downloads/hdfview-3.1.3/build
[mkdir] Created dir: /home/ps/Downloads/hdfview-3.1.3/build/classes/org.hdfgroup.object
[mkdir] Created dir: /home/ps/Downloads/hdfview-3.1.3/build/classes/org.hdfgroup.hdfview
[mkdir] Created dir: /home/ps/Downloads/hdfview-3.1.3/build/classes/hdf

create-property-file:
[propertyfile] Creating new property file: /home/ps/Downloads/hdfview-3.1.3/build/classes/hdf/versions.properties

compileobj:
[copy] Copied 2 empty directories to 2 empty directories under /home/ps/Downloads/hdfview-3.1.3/build/classes/org.hdfgroup.object

compilehdf4:
[copy] Copied 1 empty directory to 1 empty directory under /home/ps/Downloads/hdfview-3.1.3/build/classes/org.hdfgroup.object

compilefits:
[copy] Copied 1 empty directory to 1 empty directory under /home/ps/Downloads/hdfview-3.1.3/build/classes/org.hdfgroup.object

compilenc2:
[copy] Copied 1 empty directory to 1 empty directory under /home/ps/Downloads/hdfview-3.1.3/build/classes/org.hdfgroup.object

compilehdf5:
[copy] Copied 1 empty directory to 1 empty directory under /home/ps/Downloads/hdfview-3.1.3/build/classes/org.hdfgroup.object

compile:
[javac] Compiling 98 source files to /home/ps/Downloads/hdfview-3.1.3/build/classes
[javac] /home/ps/Downloads/hdfview-3.1.3/src/org.hdfgroup.object/module-info.java:10: error: module not found: jarhdf
[javac] requires jarhdf;
[javac] ^
[javac] /home/ps/Downloads/hdfview-3.1.3/src/org.hdfgroup.object/module-info.java:11: error: module not found: jarhdf5
[javac] requires jarhdf5;
[javac] ^
[javac] 2 errors

BUILD FAILED
/home/ps/Downloads/hdfview-3.1.3/build.xml:344: Compile failed; see the compiler error output for details.

Total time: 1 second

I do not know how to find the missed module jarhdf and jarhdf5.

Thanks in advance!


Jarhdf5 not found
#2

Those files are from the installation of hdf4 and hdf5 (or if you have built them, then the location of the jar files).
The build.properties file uses environment variables for those locations.


#3

Hello.

I have the same error. What is the exact files we have to find? is it really jarhdf5 or is it jhdr5.jar? I do not find any jarhdf5 or jarhdf even when building from the source. However I find some jhdf.jar and jhdf5.jar which are not in my path since I use /usr/lib64 as a path and this file are in usr/lib/java.
I tried to make a copy whitout success in usr/libs64/java

Any idea?

Thanks


#4

Maybe it’s because of compiling hdf4 via CMake-hdf-4.2.15 .

There’s a small minor bug to take note of, that can cause a missing jarhdf : See Jarhdf5 not found