SEC2 driver failure on cygwin - solved

--- Ven 13/3/09, Marco Atzeri ha scritto:

Da: Marco Atzeri
Oggetto: [hdf-forum] SEC2 driver failure on cygwin
Data: Venerdì 13 marzo 2009, 17:12
Dear All,
I am the current cygwin maintainer for hdf5,
and I succeded some time ago to port HDF5-1.6.8
with shared libs using gcc-3.4.4.
I am remaining with HDF5-1.6.x as octave can not yet
use HDF5-1.8.x

I am just trying to make the same with the new
and the build completes but "make test" instead of
"big Test" as before is performing also those tests
and stop there

#048 0x0000000050707680
#049 0x00000000236ae1a5

Test passed with the Family Driver.

Checking if file system supports big files...
Testing big file with the SEC2 Driver
Testing large dataset write


full log attached.

Two questions:
- which is the easy way to skip that "big test"
- what exactly SEC2 is and how is supposed to work ?
Just to understand if I should spend some time
trying to solve the problem or I should ignore it.

Thanks in advance

I solved both the two issues


Test passed with the SEC2 Driver.
0.07user 0.35system 0:00.86elapsed 50%CPU (0avgtext+0avgdata 785664maxresident)k
0inputs+0outputs (3091major+0minor)pagefaults 0swaps

I also discovered that on cygwin-1.7 the
--with-pthread option is working with half of
the CPU usage than before.


This mailing list is for HDF software users discussion.
To subscribe to this list, send a message to
To unsubscribe, send a message to