Predefined types unresolved symbol in Visual Studio


#1

Hello,

I am trying to compile a code using HDF5 on a Windows 10 OS with Visual Studio 2017 (x64).

I downloaded and installed the binary of HDF5 v1.12.2 (x64).

I added the include path and lib path into the corresponding Visual Studio options and specify those 2 lib: hdf5_cpp.lib hdf5.lib.

However, I still have an unresolved external symbol for: H5T_IEEE_F64LE_g and H5T_STD_I32LE_g.
It seems to be the same for any types defined in H5public.h. However the include path is good and I have the suggestion of the different predefined types.

Do I missed a static library to add?
I tried with previous versions of HDF5 binaries: 1.10.8 and 1.10.4 and I got the same problem…
I also tried to compile the library by myself using CMake (which worked well). It led to the same error during the compilation process.

It seems like I missed something but I have no idea what…

Thanks in advance,
Fabien


#2

Have you tried adding the bin path to the “PATH” env variable?