'make check' error in ubuntu 12.04

Dear people

I'm trying to install hdf5-1.8.10 or hdf-1.8.11 on the OS Ubuntu 12.04

gcc version is 4.6.4
$ gcc --version
gcc (Ubuntu/Linaro 4.6.4-1ubunyu1~12.04) 4.6.4
Copyrite (C) 2011...

szlib and zlib are built in /opt/hdf5.

I configured hdf5 from the source code.
$ cflag=-01 ./configure --prefix=/opt/hdf5 --with-szlib==/opt/hdf5

When I did 'make check', I got an error message as below
$ make check
Testing hard normalized double -> unsigned long conversions
Testing hard normalized long double -> signed char conversions
Command terminated by signal 11
0.13user 0.01system 0:00.34elapsed 43%CPU (0avgtext+0avgdata
0inputs+280outputs (0major+16369minor)pagefaults 0swaps
make[4]: *** [dt_arith.chkexe_] Error 1
make[4]: Leaving directory `..'
make[3]: *** [build-check-s] Error 2
make[3]: Leaving directory `..'
make[2]: *** [test] Error 2
make[2]: Leaving directory `..'
make[1]: *** [check-am] Error 2
make[1]: Leaving directory `..'
make: *** [check-recursive] Error 1

This error occured in hdf5-1.8.10 and hdf5-1.8.11 and optimization level -00
also yields same error with the warning '...loop counter may overflow...'
including a bunch of other warnings.

Did I miss something? Please let me know how I could fix this.

Thank you in advance.


View this message in context: http://hdf-forum.184993.n3.nabble.com/make-check-error-in-ubuntu-12-04-tp4026207.html
Sent from the hdf-forum mailing list archive at Nabble.com.

I upgraded gcc from 4.6.x to 4.7.x and solved this problem.


View this message in context: http://hdf-forum.184993.n3.nabble.com/make-check-error-in-ubuntu-12-04-tp4026207p4026211.html
Sent from the hdf-forum mailing list archive at Nabble.com.