Length discrepancy while export dataset


#1

While saving dataset (15,60) single type (32b) data to binary (LE/BE/Native) file, the expected length of the resulting file is 15604=3600 bytes.
Unexpectedly, the length was longer and i do not correctly read data from this file.
The case does not depend on dataset dimension and type.
I do not have an explanation for this phenomenon.

Thanks

Alex


#2

Would it be possible for you to provide an example to demonstrate the issue?

Thank you!

Elena


#3

It was hard to find reliability file in direct availability. Sorry for delay.
Nevertheless Any file from this list
Datasets (CM1/CM2, 60*15, 8-bit integer) have the correct exported file length (900 bytes). Its OK
But datasets with other data types adds unexpected bytes

Pressure (101 32-bit floating-point) has 408 vs. (expected) 404 bytes
DateTime (60157, 16-bit integer) has 12720 vs. (expected) 12600 bytes

While i’m searching my files I stumbled upon an unfamiliar function.
Why there is no dataset export from hdf4 files?

Thank you

Alex


#4

Thank you, Alex!

I’ve entered an issue (HDFVIEW-202 for your record) in our JIRA. We will investigate.

Elena


#5

Alex,
What version of HDFView are you using? If you are not using the latest, could you try.
Note that I have tried with HDFView 3.0 and got the correct 12600 for the DateTime dataset. A couple of things to note (and I will be investigating futher) Open the file R/W (default is R/O). Right click from the treeview to export the whole dataset. If you open the dataset and choose export, only the current page is exported (and works in both R/W and R/O file modes).

Allen


#6

My configuration consists of

  • HDFView 3.0.0
  • jre1.8.0_181
  • Windows 7

Sorry, what it means “only the current page”?

Alex


#7

That looks like the beta version. Please try with a fresh download.

There are two places that you can export data, one from the treeview context menu and one from the dataset table menu.

Allen


#8

ok, I’ve installed x64 version with included jre (8.0.660.17), HDFView.jar (18/08/17 10:54)
Worked from install menu (default path).

  • selected area [0…100] values from Pressure dataset exportes in 404 bytes
  • the same dataset from treeview gives me 408 bytes file

Alex


#9

Dear Allen,
i’ve install the new HDFview version (3.1.0) and repeated uploading dataset from main menu and from the dataset table menu. The result is repeated too. I’ve got files with different length.

Alex