ImageViewer Crash


I am trying to open a gridded HDF-4/ HDF-EOS 2 dataset as an Image, but I am getting the following error:

*** Error occurred while instantiating ImageView class ***

I am using HDFView 3.3.1 installed to my user directory - MacOS.



This seems to be a new issue, which has been experienced by a few users.
I will be investigating it as soon as I can and get it resolved before the next release this spring.

1 Like

Is it possible to provide us with a file to reproduce this issue? If it’s public, you can just point us at it. Thank you!

@gsong Sure thing. I just downloaded a day product, MOD08_D3 and received the same error. MOD08_D3.A2024057.061.2024061020430.hdf

@christine.n.brown-st , would you please tell us the output of your system environement?

Here’s a sample output of mine:

nene-[2:03pm]~/src/hdf5>uname -a
Darwin 21.6.0 Darwin Kernel Version 21.6.0: Sun Dec 17 22:55:27 PST \
2023; root:xnu-8020.240.18.706.2~1/RELEASE_X86_64 x86_64
nene-[2:14pm]~/src/hdf5>java --version
openjdk 21.0.2 2024-01-16 LTS
OpenJDK Runtime Environment Temurin-21.0.2+13 (build 21.0.2+13-LTS)
OpenJDK 64-Bit Server VM Temurin-21.0.2+13 (build 21.0.2+13-LTS, mixed mode)

I could not duplicate the error on my mac.

It would be also very helpful which dataset you tried to open in MOD08_D3 file.
I tried “Cloud_Fraction_Mean” dataset and I could see an image without crash.

Huh… I don’t have openjdk… I need it? Installing now just in case.

(base) gs619-g001399:~ cbrownst$ uname -a Darwin gs619-g001399 22.6.0 Darwin Kernel Version 22.6.0: Tue Nov 7 21:42:24 PST 2023; root:xnu-8796.141.3.702.9~2/RELEASE_ARM64_T6020 arm64

Thanks for the additional information!
We have another ARM64 Mac user who reported the same issue.

1 Like

Huh… I don’t have openjdk… I need it? Installing now just in case.

HDFView inculdes a runtime in the package.

1 Like

Installing openjdk did not work