HSDS launching only on localhost

Hello. I’m trying to run HSDS on an Azure virtual machine with podman and docker-compose. Currently I’ve managed to get the service running on the local host (i.e. I used h5pyd to store a file and then retrieved the file locally with hsget.). The next step is to be able to access the service from another machine. However, I’ve set up the hsds_endpoint= http://my_ip:5101 but the service, in particular the sn, still runs on the localhost.
I don’t understand when I can choose my ip or in which component.
Thank you for any help.

The hierarchy for deciding the HSDS endpoint is as follows:

  • If provided on the command line at startup time (to the hsds command), use that
  • Otherwise, if the environment variable HSDS_ENDPOINT exists, use that
  • Otherwise, if override.yml exists and has the key HSDS_ENDPOINT, use that
  • Otherwise, use the value in admin/config/config.yml (default http://hsds.hdf.test)

Are you using the provided runall.sh script, or directly using the docker-compose files?

Yes, I used runall.sh to run the service after setting the HSDS_ENDPOINT both in the environment variable and in config.yaml, but the service node keeps running on the local host in the sn logs, there’s this ======== Running on ========.
I’m using wsl to run the service, so the ip I supplied is that of the linux machine.

The HSDS_ENDPOINT config is not very critical – it’s used in the service responses to JSON requests to return HATEOAS links to related requests. E.g. you you send a request to fetch an attribute, the response will include a link to the parent object. It’s nice in that it lets you browse around the various links, but these links are not used by h5pyd or the REST VOL.

Anyway, if you can access the service on the machine itself (e.g. curl, then you should be able to access remotely using the machine’s IP address (assuming there’s no firewall, VPN, or port blocking in place).

Let me know if this helps.

Thank you very much for the information thanks to it I discovered the problem, in fact I was using the wsl2 to be able to run the HSDS service. However, the wsl2 linux virtual machine can’t connect to the network of the host windows machine.

Explains how to enable the windows machine to redirect requests to HSDS running on the wsl.
Now I’m able to connect to the service from a remote machine.

Can anyone tell me why when I do hsinfo I get that there is no access to the home directory but when I do hsls I get this

I don’t understand why the hstouch /home/ create a conflict and why the hsls / don’t show the home directory