HDF5 1.8.11, MVAPICH2 1.9 and PGI 13.6


My users find HDF5 really useful (thanks :), so I'm trying to build the parallel version against the various compilers and MPIs on our RHEL6 box. Unfortunately, I've hit a problem with one particular combination:

   HDF5 1.8.9
   MVAPICH2 1.8
   PGI 13.6

HDF5's "make check" doesn't complete - it gets stuck on t_cache. "top" shows 6 t_cache processes consuming CPU and never complete. I don't seem to have this problem if I use a compiler from a different vendor (GNU or Intel), or the same compiler but with intelmpi or openmpi.

In case it was a fixed bug, I tried the latest releases of each component, with the same result:

   HDF5 1.8.11
   MVAPICH2 1.9 (derived from MPICH-3.0.3)
   PGI 13.6

Build notes and output of t_cache.chklog is appended below.

Does anyone have any advice, please?




Mark Dixon Email : m.c.dixon@leeds.ac.uk
HPC/Grid Systems Support Tel (int): 35429
Information Systems Services Tel (ext): +44(0)113 343 5429
University of Leeds, LS2 9JT, UK

MVAPICH2 build notes:

   ./configure --prefix=$prefix --with-rdma=gen2 --enable-shared \
         --enable-romio --with-file-system=lustre+ufs
   make install

HDF5 build notes:

   export CC=mpicc
   export CXX=mpicxx
   export FC=mpif90
   export F77=mpif77
   export F90=mpif90
   ./configure --prefix="$prefix" --enable-parallel --disable-shared --enable-fortran --with-zlib --with-pic
   make check


  t_cache Test Log

Parallel metadata cache tests
   mpi_size = 6
   express_test = 1

*** Hint ***
You can use environment variable HDF5_PARAPREFIX to run parallel test files in a
different directory or to add file type prefix. E.g.,
    export HDF5_PARAPREFIX
*** End of Hint ***
5:setup_rand(): seed = 125651.
0:setup_rand(): seed = 125675.1:setup_rand(): seed = 3:setup_rand(): seed = 125672.4:setup_rand(): seed = 125678.

2:setup_rand(): seed = 125679.

Testing server smoke check PASSED
Testing smoke check #1 -- process 0 only md write strategy