Error when install HDF5: HDF5/1.10.2/lib/libz.so.1: no version information available


#1

Dear,

I installed HDF5 by cmake on 64-bit Ubuntu 16.04 and add the following configurations in ~/.bashrc:

export HDF5SYS=/opt/HDF5/CMake-hdf5-1.10.2/build/HDF5-1.10.2-Linux/HDF_Group/HDF5/1.10.2
export PATH=$PATH:$HDF5SYS/bin
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$HDF5SYS/lib

Then whenever I start VIM I will get the following messages, but they disappear if I comment the fourth line above.

vim: /opt/HDF5/CMake-hdf5-1.10.2/build/HDF5-1.10.2-Linux/HDF_Group/HDF5/1.10.2/lib/libz.so.1: no version information available (required by /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0)
vim: /opt/HDF5/CMake-hdf5-1.10.2/build/HDF5-1.10.2-Linux/HDF_Group/HDF5/1.10.2/lib/libz.so.1: no version information available (required by /usr/lib/x86_64-linux-gnu/libpython3.5m.so.1.0)
vim: /opt/HDF5/CMake-hdf5-1.10.2/build/HDF5-1.10.2-Linux/HDF_Group/HDF5/1.10.2/lib/libz.so.1: no version information available (required by /usr/lib/x86_64-linux-gnu/libtcl8.6.so)
vim: /opt/HDF5/CMake-hdf5-1.10.2/build/HDF5-1.10.2-Linux/HDF_Group/HDF5/1.10.2/lib/libz.so.1: no version information available (required by /usr/lib/x86_64-linux-gnu/libtcl8.6.so)
vim: /opt/HDF5/CMake-hdf5-1.10.2/build/HDF5-1.10.2-Linux/HDF_Group/HDF5/1.10.2/lib/libz.so.1: no version information available (required by /usr/lib/x86_64-linux-gnu/libxml2.so.2)
vim: /opt/HDF5/CMake-hdf5-1.10.2/build/HDF5-1.10.2-Linux/HDF_Group/HDF5/1.10.2/lib/libz.so.1: no version information available (required by /usr/lib/x86_64-linux-gnu/libxml2.so.2)

Any help would be greatly appreciated.