Building fails on SurfSARA with Fortran and in parallel


#1

Hello HDF Group users,

I’m attempting to build HDF5 1.10.4 on the HPC Cartesius at the Dutch supercomputing center SurfSARA. I’m currently trying to build for parallel using OpenMPI 3.1.1 and GCC 7.3.0 and its failing on trying to compile any Fortran files. The relevant portion of the config.log is here:

1880 configure:6652: checking whether /hpc/eb/RedHatEnterpriseServer7/OpenMPI/3.1.1-GCC-7.3.0-2.30/bin/mpifort accepts -g
1881 configure:6663: /hpc/eb/RedHatEnterpriseServer7/OpenMPI/3.1.1-GCC-7.3.0-2.30/bin/mpifort -c -g conftest.f >&5
1882 : internal compiler error: Illegal instruction
1883 0xae71df crash_signal
1884 …/…/gcc/toplev.c:337
1885 Please submit a full bug report,
1886 with preprocessed source if appropriate.
1887 Please include the complete backtrace with any bug report.
1888 See https://gcc.gnu.org/bugs/ for instructions.
1889 configure:6663: $? = 1
1890 configure: failed program was:
1891 | program main
1892 |
1893 | end
1894 configure:6671: result: no
1895 configure:6704: checking for Fortran flag to compile .f90 files
1896 configure:6724: /hpc/eb/RedHatEnterpriseServer7/OpenMPI/3.1.1-GCC-7.3.0-2.30/bin/mpifort -c conftest.f90 >&5
1897 : internal compiler error: Illegal instruction
1898 0xae71df crash_signal
1899 …/…/gcc/toplev.c:337
1900 Please submit a full bug report,
1901 with preprocessed source if appropriate.
1902 Please include the complete backtrace with any bug report.
1903 See https://gcc.gnu.org/bugs/ for instructions.
1904 configure:6724: $? = 1
1905 configure: failed program was:
1906 | program main
1907 |
1908 | end
1909 configure:6724: /hpc/eb/RedHatEnterpriseServer7/OpenMPI/3.1.1-GCC-7.3.0-2.30/bin/mpifort -c -qsuffix=f=f90 conftest.f90 >&5
1910 gfortran: error: unrecognized command line option ‘-qsuffix=f=f90’
1911 configure:6724: $? = 1
1912 configure: failed program was:
1913 | program main
1914 |
1915 | end
1916 configure:6724: /hpc/eb/RedHatEnterpriseServer7/OpenMPI/3.1.1-GCC-7.3.0-2.30/bin/mpifort -c -Tf conftest.f90 >&5
1917 : internal compiler error: Illegal instruction
1918 0xae71df crash_signal
1919 …/…/gcc/toplev.c:337
1920 Please submit a full bug report,
1921 with preprocessed source if appropriate.
1922 Please include the complete backtrace with any bug report.
1923 See https://gcc.gnu.org/bugs/ for instructions.
1924 configure:6724: $? = 1
1925 configure: failed program was:
1926 | program main
1927 |
1928 | end
1929 configure:6724: /hpc/eb/RedHatEnterpriseServer7/OpenMPI/3.1.1-GCC-7.3.0-2.30/bin/mpifort -c -x f95 conftest.f90 >&5
1930 : internal compiler error: Illegal instruction
1931 0xae71df crash_signal
1932 …/…/gcc/toplev.c:337
1933 Please submit a full bug report,
1934 with preprocessed source if appropriate.
1935 Please include the complete backtrace with any bug report.
1936 See https://gcc.gnu.org/bugs/ for instructions.
1937 configure:6724: $? = 1
1938 configure: failed program was:
1939 | program main
1940 |
1941 | end
1942 configure:6733: result: unknown
1943 configure:6736: error: Fortran could not compile .f90 files

I would attach the full log also for you to look at, but new users cannot attach any files. I’ve also tried prepending the correct locations for everything just before the configure command like this:

CC=$MPICC CXX=$MPICXX FC=$MPIFC ./configure --enable-static --enable-shared --enable-fortran --enable-cxx --prefix=/home/jwall/local/hdf5

Where the locations of all the relevant MPI wrappers are present. I’ve also tested that both gfortran and mpifort accept the -g argument on their own, and they work fine. Any assistance is appreciated.

Thanks,

Josh

Joshua Wall

Doctoral Candidate
Department of Physics
Drexel University