Query if built with MPI support


#1

Is there an API to query if the library was built with MPI support (analogous to H5is_library_threadsafe)?


#2

Simon, how are you? I’m not aware of a comparable function for MPI support. Which HDF5 version (1.8, 1.10, 1.12) are you using? There are a few hacky ways to get that information, but you’d be relying on implementation details. It’s easy enough to implement in the library. Would you please submit an improvement request via Jira or the helpdesk? Thanks, G.


#3

Thanks for your reply, i opened a ticket here: https://jira.hdfgroup.org/servicedesk/customer/portal/2/SUPPORT-1045