Error in using HDF5 with FLASH4

When I tried to execute the FLASH code the following error was generated:

**HDF5-DIAG: Error detected in HDF5 (1.12.0) thread 0:
#000: H5Ddeprec.c line 149 in H5Dcreate1(): invalid location identifier
major: Invalid arguments to routine
minor: Inappropriate type
#001: H5VLint.c line 1696 in H5VL_vol_object(): invalid identifier type to function
major: Invalid arguments to routine
minor: Inappropriate type
flash4: io_h5create_dataset.c:57: io_h5create_dataset: Assertion `dataset >= 0’ failed.

Program received signal SIGABRT: Process abort signal.

Backtrace for this error:
#0 0x7fc427b3acb1 in ???
#1 0x7fc427b39e75 in ???
#2 0x7fc42780546f in ???
#3 0x7fc4278053eb in ???
#4 0x7fc4277e4898 in ???
#5 0x7fc4277e4768 in ???
#6 0x7fc4277f6005 in ???
#7 0x55a0b9c91655 in io_h5create_dataset
at /home/binayyak/flash4_fishergroup/object/io_h5create_dataset.c:57
#8 0x55a0b9c8e2a5 in io_create_dataset_
at /home/binayyak/flash4_fishergroup/object/io_create_dataset.c:35
#9 0x55a0b9c8de9b in io_createdatasets_
at /home/binayyak/flash4_fishergroup/object/io_createDatasets.F90:82
#10 0x55a0b9c9c399 in io_writedata_
at /home/binayyak/flash4_fishergroup/object/io_writeData.F90:180
#11 0x55a0b9c0fbce in io_writecheckpoint_
at /home/binayyak/flash4_fishergroup/object/IO_writeCheckpoint.F90:129
#12 0x55a0b9c0f6cc in io_outputinitial_
at /home/binayyak/flash4_fishergroup/object/IO_outputInitial.F90:76
#13 0x55a0b9bf4eeb in driver_initflash_
at /home/binayyak/flash4_fishergroup/object/Driver_initFlash.F90:221
#14 0x55a0b9beea63 in flash
at /home/binayyak/flash4_fishergroup/object/Flash.F90:49
#15 0x55a0b9beea63 in main
at /home/binayyak/flash4_fishergroup/object/Flash.F90:43

Primary job terminated normally, but 1 process returned
a non-zero exit code. Per user-direction, the job has been aborted.**

Kindly do help me out with this if possible.

Which version of Flash are you trying to run? Did you build it yourself? If so, how? Is your Flash version compatible with HDF5 1.12? You might have better luck with HDF5 1.10.x

Respected Sir,

Thanks a lot for getting back to me. I really appreciate the help. I am using flash4. I think it is compatible with HDF5-1.12.0.

However I did get the following reply from HDF5 personnel:

Hello Binayyak,

I can see that the error occurs with the H5Dcreate1 API. That function
was deprecated in HDF5-1.8 in favor of H5Dcreate2 (which has an additional
parameter for a property list).

It looks like Flash may have been built with HDF5-1.6 or at least with
the h5Dcreate1 API.

Try building it with the following api compatibility macros:


First try the 1.10 macro, as that may work.
If that does not, then try the 1.6 macro. For example, if using the
HDF5 compile script ‘h5cc’, type:

h5cc -DH5_USE_16_API myprogram.c

See this page for further information on the API compatibility macros:



However, I am still not sure how to execute this common or in which directory I should execute it. Could you please guide me a little bit?

Yours sincerely,

Binayyak Bhusan Roy